twitter-bootstrap-railsを普通にWindowsで使おうとするとlibv8がないからアカンで~的なエラーが出てきてインストールに失敗します。

対策

特定のバージョンはインストールできるのでそれをインストールしましょう。

gem install libv8 --version 3.11.8.0

あとはGemfilegem 'therubyracer', platforms: :rubyのコメントアウトを外してgem twitter-bottstrap-railsを追加すれば万事OK!

追記、より良い解決策

そもそもbootstrap-sassを使えばよいのでは?


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Post Navigation