rails new したらbundle install が atomic の所でコケた。何か前も同じエラーに引っかかって結構検索した記憶があったんだけど今回も対処法を探すのに結構な時間がかかってしまった。

エラーメッセージはこんなの。

解決策

エラーメッセージからだと全くわからないんだけれども、どうやらこれは Xcodeのバージョンをアップとか新規インストールした時に一度立ち上げて利用規約にOKと答えておかないとコンパイラーが使えずにでるらしい。

なので、Xcodeを一度立ち上げて規約にOKしたら解決。と前回はここで解決したんですがどうやら今回はこれだけじゃだめらしい。

今度こそ解決策

Commandline toolsを再インストールするために xcode-select --installしたら解決しました!
Maverickに上げたのが原因らしいです。
自分の場合はターミナルの再起動するまでCommandline toolsのアップデートが認識できませんでしたが必須なのかどうかはわかりません。

参考

Ruby – Mac OS X 10.9 Mavericks で Rails の bundle install に失敗する件の対処法 – Qiita [キータ]